Fix update issues - Centos / Ngixx

Fix update issues - Centos / Ngixx

Cancelled

Job Description

When updating various packages i am getting the following issues:

Error: Multilib version problems found. This often means that the root
cause is something else and multilib version checking is just
pointing out that there is a problem. Eg.:

1. You have an upgrade for php-common which is missing some
dependency that another package requires. Yum is trying to
solve this by installing an older version of php-common of the
different architecture. If you exclude the bad architecture
yum will tell you what the root cause is (which package
requires what). You can try redoing the upgrade with
--exclude php-common.otherarch ... this should give you an error
message showing the root cause of the problem.

2. You have multiple architectures of php-common installed, but
yum can only see an upgrade for one of those arcitectures.
If you don't want/need both architectures anymore then you
can remove the one with the missing update and everything
will work.

3. You have duplicate versions of php-common installed already.
You can use "yum check" to get yum show these errors.

...you can also use --setopt=protected_multilib=false to remove
this checking, however this is almost never the correct thing to
do as something else is very likely to go wrong (often causing
much more problems).

Protected multilib versions: php-common-5.4.17-23.el6.art.x86_64 != php-common-5.3.25-18.el6.art.i686
You could try using --skip-broken to work around the problem
You could try running: rpm -Va --nofiles --nodigest
.. install failed!

AND

Error: Package: php-magickwand-1.0.9.2-3.el6.remi.x86_64 (remi)
Requires: php(zend-abi) = 20100525-x86-64
Installed: php-common-5.3.25-18.el6.art.i686 (@atomic)
php(zend-abi) = 20090626
php(zend-abi) = 20090626-x86-32
Available: php-common-5.4.17-23.el6.art.i686 (atomic)
php(zend-abi) = 20100525-x86-32
Error: Package: php-magickwand-1.0.9.2-3.el6.remi.x86_64 (remi)
Requires: php(api) = 20100412-x86-64
Installed: php-common-5.3.25-18.el6.art.i686 (@atomic)
php(api) = 20090626
php(api) = 20090626-x86-32
Available: php-common-5.4.17-23.el6.art.i686 (atomic)
php(api) = 20100412-x86-32
You could try using --skip-broken to work around the problem
You could try running: rpm -Va --nofiles --nodigest

AND